Korg Monopoly - No Sound

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.

Korg Monopoly - No Sound

Postby changeofeyes » Tue Aug 20, 2013 2:00 am

I'm about to pick up a Korg Monopoly with custom case for $200. The owner had it for 30 years, he said it powers up but doesnt produce sound. Does anyone know what the issue might be? If it's common or fixable?
User avatar
changeofeyes
Newbie
Newbie
 
Posts: 84
Joined: Wed Dec 24, 2008 6:44 pm
Location: upstate NY
Gear: Moog Voyager, Roland SH-101, TR-707, Juno-106, MC-808, Korg MS2000, Casio CT-640 and various pedals.
Band: TSTI

Advertisement:

Re: Korg Monopoly - No Sound

Postby rhino » Tue Aug 20, 2013 4:58 pm

For $200, you can't go wrong !! (IMHO). Take it to a good tech and spend $400-500 on repairs and you'll still come out ahead.

Too many posibilities to do much good via text.

1) Power supply (esp. op-amp rails)
2) Broken/corroded output jack (Does headphone out work?)
3) Dead volume pot.
4) Mice/idiots at work inside.
5) Dead VCF
6) Dead VCA
Reason says: "There are questions that can't be answered."
Religion says: "There are answers that can't be questioned."
User avatar
rhino
Supporting Member!
Supporting Member!
 
Posts: 2469
Joined: Sat Aug 02, 2008 5:00 pm
Location: kentucky hills
Real name: bill
Gear: keepers:
Kurzweil K2500x
Ensoniq TS-12
Yamaha SY-99
Alesis QS-8
Roland JD-800
Roland JX-10
Akai AX-80
Ensoniq SQ-80
Korg DSS-1
Moog Mini
Fizmo


Return to HELP!

Who is online

Users browsing this forum: No registered users and 5 guests