Rhodes Chroma Polaris only plays every 5-6 notes

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.

Rhodes Chroma Polaris only plays every 5-6 notes

Postby DoctorEternal » Sun Apr 05, 2009 4:31 pm

I was recently given a beautiful Rhodes Chroma Polaris, but it only plays every 5-6 notes (which seem to vary). There doesn't appear to be a key contact problem, as the same thing occurs when I play it via an external MIDI controller.

Anyone?
Dr.E
DoctorEternal
Newbie
Newbie
 
Posts: 1
Joined: Sun Apr 05, 2009 4:20 pm

Advertisement:

Re: Rhodes Chroma Polaris only plays every 5-6 notes

Postby MPPelli » Thu May 28, 2009 6:51 pm

Have you checked that all six voices are on? Press Lower function and E. Leds 1 to 6 should be lit. Polaris automatically turns off voices that are faulty (or somebody did that manually by accident) but you can force them on by pressing the corresponding number switch and the led should light up.

Press Lower function again to return to normal operation mode.

If the problem is still there some of the voice chips might be damaged.
User avatar
MPPelli
Supporting Member!
Supporting Member!
 
Posts: 4
Joined: Sun May 24, 2009 12:24 am
Location: Jyvaskyla, Finland
Gear: Minimoog #6853 | Andromeda | Chroma Polaris | MKS-80 + MPG-80 | Mono/Poly| JD-800 | K5000R | Microwave XT | etc. etc.

Re: Rhodes Chroma Polaris only plays every 5-6 notes

Postby justinvm » Mon Jun 01, 2009 5:26 am

Try auto tune. It usually re-calibrates the voices so that they work. If voices are still missing then you probably have a hardware problem.
justinvm
Junior Member
Junior Member
 
Posts: 209
Joined: Sat Jul 07, 2007 12:03 pm


Return to HELP!

Who is online

Users browsing this forum: No registered users and 8 guests