Yamaha CS20M - Drifting VCO and Memory Fail

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.

Yamaha CS20M - Drifting VCO and Memory Fail

Postby winningatlife » Wed Apr 29, 2009 11:29 pm


I can not find ANYBODY who knows much of anything about the CS20M - It works just fine, sounds great, BUT, VCO 2 is a bit drifty for the first 30 min its on...

AND, the memory function no longer works.

Anybody ever worked on one of these beasts?

Some keys I have: Yamaha CS20M, ARP Axxe, Chroma Polaris, Roland Juno 60, Vermona DRMMKII, Roland R8, Sequential Circuits Pro-One, x0xbox, Terratec MB 33 II Superbass, Kurzweil SP88.
User avatar
Posts: 45
Joined: Wed Apr 29, 2009 10:58 pm
Location: Los Angeles
Real name: Ryan
Gear: Yamaha CS20M
Arp Axxe
Juno 60
Sequential Circuits Pro-One
Vermona DRMMK2
Roland R8
Kurzweil SP88
Chroma Polaris
Band: Agape


Re: Yamaha CS20M - Drifting VCO and Memory Fail

Postby Steve Jones » Thu Apr 30, 2009 12:47 am

There is a battery compartment on the underside on the synth if you turn it over, have you tried changing the batteries?
Synthesizer service tech since 1982.
Synth parts and service, Sydney Australia.

User avatar
Steve Jones
Active Member
Active Member
Posts: 553
Joined: Wed Apr 23, 2008 10:40 pm
Location: Sydney

Return to HELP!

Who is online

Users browsing this forum: Bing [Bot] and 15 guests