Loud pop when turning on Moog Rogue

Discussions about anything analog, digital, MIDI, synth technology, techniques, theories and more.

Loud pop when turning on Moog Rogue

Postby madphingers » Mon Nov 14, 2011 7:13 am

I recently got a Rogue and have been loving it. But I notice when I turn it on while it is plugged into my bass rig, there is a really loud pop through the speakers. I may have even burnt out my 18" driver on my Acoustic 301 cab because of this.... :|

Anyone know if this pop is normal and I should just turn the synth on before my amp? Or do I have something going on here. It is also worth noting when I plug in the power supply to the synth, I see a flash of electricity inside by the jack.
madphingers
Newbie
Newbie
 
Posts: 4
Joined: Mon Nov 14, 2011 7:02 am

Advertisement:

Re: Loud pop when turning on Moog Rogue

Postby mharris80 » Mon Nov 14, 2011 7:40 am

No matter what kind of sound reinforcement is used, it's always a good practice to turn the amps on last. Period.
mharris80
Junior Member
Junior Member
 
Posts: 209
Joined: Tue Dec 18, 2007 9:24 pm
Location: Robinson, IL
Gear: Korg M1
MicroKorg
Ensoniq ASR 88
Ensoniq ESQ-1
Roland JX-8P
Roland MKS-50
Yamaha RX7
M Audio Oxygen 49
AV Linux

Re: Loud pop when turning on Moog Rogue

Postby Alex E » Mon Nov 14, 2011 9:35 am

Yup. That's normal. Gotta turn on your amps/speaker/mixer last.
soundcloud.com/vectron

User avatar
Alex E
Synth Explorer
Synth Explorer
 
Posts: 2218
Joined: Sat Dec 02, 2006 12:07 am
Location: Anaheim, CA
Gear: Alpha Juno 2, Live 8, iMac MC309XX/A

Re: Loud pop when turning on Moog Rogue

Postby Phollop Willing PA » Mon Nov 14, 2011 3:57 pm

Or at least mute the mixer or amp's volume.
MOOGSig: Voyager/Theremin, ROLAND: JP8000/MC505/MC50/SH1000/Octapad1/RE 20, CASIO VLtone, KORG: Kronos73/Prophecy/MS2000R/Kaos Pad2/D3200/D888/SDD4000/M3, BOSS SP202/DR110, YAMAHA:CS40M/QX7/WX7/QY10, ARP Exp, MACBETH M5, FR ORB, SONNET, ALESIS SR18
User avatar
Phollop Willing PA
Senior Member
Senior Member
 
Posts: 839
Joined: Sun May 04, 2008 3:47 pm
Location: Nova Scotia
Gear: Korg, Moog, Roland, Alesis, ARP, Yamaha, Future Retro

Re: Loud pop when turning on Moog Rogue

Postby madphingers » Mon Nov 14, 2011 4:17 pm

Ok, thanks for the replies. Now if I may, I'd like to hijack my own thread and ask another question...

Does anyone know the specs for replacement slide pot for the Rogue. I am aware there are 3 or 4 different ones you need to use.

I need to know:

Resistance
Wattage
Size/Dimensions
Series
Adjustment Type

I would like to try and order some from Digikey or Mouser to save a little money if I can..
madphingers
Newbie
Newbie
 
Posts: 4
Joined: Mon Nov 14, 2011 7:02 am

Re: Loud pop when turning on Moog Rogue

Postby Phollop Willing PA » Mon Nov 14, 2011 4:21 pm

I'd start a new thread on that subject if I were you... ;)
MOOGSig: Voyager/Theremin, ROLAND: JP8000/MC505/MC50/SH1000/Octapad1/RE 20, CASIO VLtone, KORG: Kronos73/Prophecy/MS2000R/Kaos Pad2/D3200/D888/SDD4000/M3, BOSS SP202/DR110, YAMAHA:CS40M/QX7/WX7/QY10, ARP Exp, MACBETH M5, FR ORB, SONNET, ALESIS SR18
User avatar
Phollop Willing PA
Senior Member
Senior Member
 
Posts: 839
Joined: Sun May 04, 2008 3:47 pm
Location: Nova Scotia
Gear: Korg, Moog, Roland, Alesis, ARP, Yamaha, Future Retro

Re: Loud pop when turning on Moog Rogue

Postby madphingers » Mon Nov 14, 2011 4:24 pm

will do thanks!
madphingers
Newbie
Newbie
 
Posts: 4
Joined: Mon Nov 14, 2011 7:02 am


Return to General Synthesizers

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 16 guests