Korg ESX-1 Electribe - Knobs/Arp unresponsive

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.

Korg ESX-1 Electribe - Knobs/Arp unresponsive

Postby somebedroomdj » Tue Oct 29, 2013 1:42 pm

Hello,

I picked one of these up on Ebay for very cheap with the understanding that the arpeggiator and FX knobs would not be working. As it turns out, ALL knobs are unresponsive except for the main volume, tube gain and input level (all located in the upper left). Oh, and the FX select encoder works as well. All the buttons seem to work, it will play a pattern, allow assignment of samples, can access all menus, audio output is fine.

Now, I've read about the "baking paper trick" and I was wondering, has anyone had a similar situation to mine (not knob jitter, but total unresponsiveness) and had it fixed with the baking paper trick?

I've also seen where one of the cables connecting the two boards can become loose and cause jitter so I thought maybe it came out all the way and caused my issue. But I went in and it did not appear loose in the slightest.

Anything else I can try, short of trying to source a new board or something like that?
Synths: | Spectralis 1 | JP-8000 | Bass Station 2 | Minibrute | TT-303 | MC-09 | EF-303| Volca Keys & Bass
Samplers/Drums/Etc: | MC-909 | ESX-1 | SP-808 | Volca Beats
User avatar
somebedroomdj
Newbie
Newbie
 
Posts: 90
Joined: Sat Oct 16, 2010 6:37 pm
Location: Wisconsin

Return to HELP!

Who is online

Users browsing this forum: No registered users and 4 guests