Kawai K4 - won't start up

Pulling out your hair? Don't know what to do or where to go? Ask in here.
Forum rules
READ: VSE Board-Wide Rules and Guidelines

If your Help request has been solved, please edit your first post in order to select the Image Topic Icon to let others know your topic has been solved.

Kawai K4 - won't start up

Postby archiesmum » Sun Mar 23, 2014 3:10 pm

Hi All

I've dug out my Dad's old synth to learn Piano on and it won't seem to load anything up. I'm using with headphones for now and no sound is coming out and the display is stuck on the initial welcome message.

Does anyone have any idea of what I need to do/ look at?

Many thanks in advance!
archiesmum
Newbie
Newbie
 
Posts: 2
Joined: Sun Mar 23, 2014 3:04 pm

Advertisement:

Re: Kawai K4 - won't start up

Postby archiesmum » Sun Mar 23, 2014 9:25 pm

All sorted now. I opened the back up, wiggled a few wires, blew the dust away and started again.
archiesmum
Newbie
Newbie
 
Posts: 2
Joined: Sun Mar 23, 2014 3:04 pm

Re: Kawai K4 - won't start up

Postby rhino » Sun Mar 23, 2014 10:21 pm

Good work!
Welcome to the board.
The K-4 is a crazy little synth - makes good sci-fi/horror pads.

The flat cables that "clamp" in to sockets on the main board are a source of problems. Maybe want to someday take them loose, use "DeOxIt" or similar and put them back making sure the 'clamps' close tight.
"A thing may seem impossible...until it's done."
--Nelson Mandela
User avatar
rhino
Supporting Member!
Supporting Member!
 
Posts: 2494
Joined: Sat Aug 02, 2008 5:00 pm
Location: kentucky hills
Real name: bill
Gear: keepers:
Kurzweil K2500x
Ensoniq TS-12
Yamaha SY-99
Alesis QS-8
Roland JD-800
Roland JX-10
Akai AX-80
Ensoniq SQ-80
Korg DSS-1
Moog Mini
Fizmo


Return to HELP!

Who is online

Users browsing this forum: No registered users and 1 guest